Getting closer to MOT!

Anything about BXs
User avatar
Vanny
Merseyside resident
Merseyside resident
Posts: 3421
Joined: Tue May 17, 2005 11:48 pm
Location: BX Pub
My Cars: BX 16v Ph2
x 11

Post by Vanny » Fri Jun 24, 2005 6:37 pm

funny thing is i have two of them! and there both KKK!

Tahnks for the offer Jon, as said i have two spare turbo's and i actually have a spare head that i've been holding for a few months, however the one on the car is nearly brand new!



As a brief update, i dropped a gear to overtake another car on the A55 earlier and no longer have a whining turbo, infact i dont really have a turbo any more! Once it gets above 0.5 bar, oil levels rapidly diminish (about 100 miles per litre when driven hard) and it seriously sounds like there is a jet engine under the car. Think the various seals have totally failed now!


Oh the hesitation has reappeared and the nice man who lent me the stop solenoid thinks its bits in the pump coliding and bits coming off inside the pump!


So, i have an engine that has slipped its belt requiring a new head and having left marks on the pistons! A fuel pump literally falling to bits, and a blown up turbo! Total cost in parts to FIX the engine are pretty much at £100, so all in all after i've fixed the pump and turbo i probably could have bought a HDi and stuck that in! Typical!

Stewart (oily!)
1K Away
1K Away
Posts: 1604
Joined: Wed May 18, 2005 6:23 pm
Location: North Wales

Post by Stewart (oily!) » Fri Jun 24, 2005 6:50 pm

Vanny I have a spare lucas pump off the engine in my garage, you can have it FOC if you want it, just pop over and pick it up.
Stewart
TZD 19 TD one of the few
Xantia Td estate, going soft

Stewart (oily!)
1K Away
1K Away
Posts: 1604
Joined: Wed May 18, 2005 6:23 pm
Location: North Wales

Post by Stewart (oily!) » Sat Jun 25, 2005 4:47 pm

Sounds about right there Jon, if possible a Bosch pump but there is a free lucas one available.
Stewart
TZD 19 TD one of the few
Xantia Td estate, going soft

tom
Citroen Sorceror
Posts: 1239
Joined: Fri May 20, 2005 8:51 pm
Location: straddling the channel

Post by tom » Sun Jun 26, 2005 4:08 pm

If that's the Bosch kit off the Grey one, I'll be wanting to deal with you.

User avatar
Vanny
Merseyside resident
Merseyside resident
Posts: 3421
Joined: Tue May 17, 2005 11:48 pm
Location: BX Pub
My Cars: BX 16v Ph2
x 11

Post by Vanny » Tue Jun 28, 2005 10:03 pm

is there any easy way to clean out the pump? It seems to have bits in it again!

The nice man Carl Roberts suggested i might be better off getting a new pump, as its probably the bearing or something on there way out!


How much for yours Jon? Might have to wait a week or two until im working again!

User avatar
Vanny
Merseyside resident
Merseyside resident
Posts: 3421
Joined: Tue May 17, 2005 11:48 pm
Location: BX Pub
My Cars: BX 16v Ph2
x 11

Post by Vanny » Thu Jun 30, 2005 11:04 am

Think the rate im going im gonna have to have a trip down to visit you jon!

The saga continues!

as mentioned before when the engine change was done the bolts holding the intermediary joint on the long side drive shaft (BX16v) weren't tightened up! Found it when said relacement engine needed a head change, but had done a good 1000 miles on it! Oil seal was destroyed on the diff box.

Now when driving and on a full right hand lock there is a very loud routine thunk thunk thunk at the same speed as the road wheel rotation. Can i assume this is gonna be down to a goosed driveshaft?


I think im havign a rather bad car year! THough now i know better than to trust a dodgy looking engine, it has become the baine of my life thats for sure! would have been faster and cheaper to rebuild the 1.9td in situe, and if i had know how buggered the replacement engine really was i would have never bothered :(

User avatar
Vanny
Merseyside resident
Merseyside resident
Posts: 3421
Joined: Tue May 17, 2005 11:48 pm
Location: BX Pub
My Cars: BX 16v Ph2
x 11

Post by Vanny » Thu Jun 30, 2005 1:39 pm

Cheers Jon, i do have a long side drive shaft, but im not totally sure that its ABS nor do i know what state it's in, though it doesnt look too bad!

Who knows how many more problems i will find!

AndyC
New Member
Posts: 4
Joined: Sat Jun 18, 2005 3:39 pm

Post by AndyC » Mon Jul 04, 2005 1:11 am

I wouldn't trust that engine mate the bottom end wasn't that good either if you remember what we found when we did the head job.What condition is the 1. 9 in now ?

User avatar
Vanny
Merseyside resident
Merseyside resident
Posts: 3421
Joined: Tue May 17, 2005 11:48 pm
Location: BX Pub
My Cars: BX 16v Ph2
x 11

Post by Vanny » Mon Jul 04, 2005 9:48 am

go and read the other post and get up to date Andy! The engine has totally died!