306 smell, could it be the matrix?

post here until we fix the rest of your forum
pug_owner2002
New Member
Posts: 9
Joined: Fri Nov 02, 2007 7:47 pm

306 smell, could it be the matrix?

Post by pug_owner2002 » Wed Nov 28, 2007 9:24 pm

Hi All,

I have got a 2001 X reg 306 1.4 that has don 97k, I have started to notice a smell inside the car which is worse when the blower is not running, the smell to me is like a curry kind of smell.
Could this be as I suspect, the matrix starting to fail?
I have not checked the water level yet to see if it has gone down as the engine is still hot, I will check it in the morning.

Any help/coments appreciated.

User avatar
CitroXim
Sir Jim of the Databases
Posts: 788
Joined: Wed Oct 31, 2007 9:08 pm
Location: Newport Pagnell
x 2

Post by CitroXim » Wed Nov 28, 2007 10:16 pm

Yes, sadly, that is the first sign :(

However, having said that, they can go on a long time smelling a little and not leaking any significant amount of coolant.

All my Xantias smell a bit but only briefly. My Activa was worse at the start of winter. It seems where the flaps were closed against the matrix all summer, a bit of coolant built up and smelt for a bit. Touch wood, it has all gone off now.

I understand doing a 306 matrix is nearly as much of a task as a Xantia. The dash has to come right out :twisted:
Jim

'98 Xantia 1.9TD in Red - Gabriel the Bus...
'96 Xantia Activa in Red - My favourite toy...
'07 Pug 207 in Blue - The Deathtrap...
'15 Giant Defy Bike in Blue - Daily rider...
'16 Giant TCR Bike in Black/Lime Green - Fine weather only...

pug_owner2002
New Member
Posts: 9
Joined: Fri Nov 02, 2007 7:47 pm

Post by pug_owner2002 » Wed Nov 28, 2007 10:31 pm

Thanks Citrojim,

You have confirmed what I suspected.
I'll have to see how it goes and potentially get it replaced. :cry:

jeremy
Over 2k
Posts: 2112
Joined: Fri Jul 01, 2005 2:58 am
Location: Hampshire UK

Post by jeremy » Thu Nov 29, 2007 8:41 am

Glycol anti-freeze smells sweet - not like curry.

There were a number of posts on curry smells some time ago and apparently it can be a bacterial contamination of the matrix - which can be shifted with a specialist product - Halfords?

More common with air conditioning.

Other signs of leaky matrix is misting of the screen on startup (heater on etc - damp air condenses on screen)

Xantiaman
Confirmed BX'er
Posts: 28
Joined: Thu Nov 01, 2007 7:30 am

Post by Xantiaman » Thu Nov 29, 2007 9:23 am

If it is leaking try some K-Seal. I added some to my Xantia which showed signs of a leaking matrix so i waited until after the water pump/cambelt was done and added a bottle, it doesnt mist the screen up anymore, or smell. It's worth it for a tenner to save the hassle.

Gareth
Xantia ActivaLX - Fuelled by SVO

pug_owner2002
New Member
Posts: 9
Joined: Fri Nov 02, 2007 7:47 pm

Post by pug_owner2002 » Sun Dec 02, 2007 4:22 pm

Hi all,

Thanks for the replys.
It's been a couple of years since I used the air con cleaning stuff from halfords so it probably is worth me buying that and seeing if it helps.
I will continue to keep an eye on the coolant level as it does not appear to be using water, if it does though I think I'll go down the route suggested by Xantiaman and try some K-Seal.

Thanks again!