Rear Hieght Corrector

post here until we fix the rest of your forum
kingpleb
New Member
Posts: 8
Joined: Wed Nov 28, 2007 10:19 pm
Location: Near Doncaster, South Yorks

Rear Hieght Corrector

Post by kingpleb » Thu Nov 29, 2007 10:17 am

With the normal forum still down :(

The rear of my xantia doesnt like to settle into the normal hieght position by itself, off the lever it will either go to full hieght or lowest and only sits on normal at the rear if i play with the control lever to let the pressure flow thru on full hieght then quickly move it back to normal when at the desired.

Im pretty sure its the hieght corrector starting to sieze up and have given the outside of it a quick clean and then lubed it up with WD40 and moved the lever around a fair bit to work it in but still no luck :(

Is this a DIY-able job that can be done on the driveway? Or as a guess only for somewhere with a 4post lift? Also whats the going rate for this job being done as £120+vat rings a bell?

Thanks all for any help and to the BX Club for hosting us while we are still homeless :)
Xantia Mk2 2.1TD SX
Xantia Mk2 1.9td LX(99v)
C2 1.4 Furio Sensodrive
Toyota Auris 1.4D-4D EMMT

Xantiaman
Confirmed BX'er
Posts: 28
Joined: Thu Nov 01, 2007 7:30 am

Post by Xantiaman » Thu Nov 29, 2007 10:28 am

I had the front height corrector linkage pop off on me last week, same symptoms but the correct itself was not seized, the front is more likely to get oil on it preventing this. Access to the rear one is easier, i got my car up on a lift to lube up the linkage but with suspension on full height the linkage itself will be under tension, thing its best to put suspension to its lowest setting once the car has been jacked up and put on axle stands. Do you know for certain if the linkage is still connected to the ARB?

Gareth
Xantia ActivaLX - Fuelled by SVO

kingpleb
New Member
Posts: 8
Joined: Wed Nov 28, 2007 10:19 pm
Location: Near Doncaster, South Yorks

Post by kingpleb » Thu Nov 29, 2007 3:35 pm

Ill give it a check sometime tonight but i think it is from what i could see.
Xantia Mk2 2.1TD SX
Xantia Mk2 1.9td LX(99v)
C2 1.4 Furio Sensodrive
Toyota Auris 1.4D-4D EMMT

kingpleb
New Member
Posts: 8
Joined: Wed Nov 28, 2007 10:19 pm
Location: Near Doncaster, South Yorks

Post by kingpleb » Thu Nov 29, 2007 7:42 pm

Thank you Xantiaman :)

Have to go to citroen tomorrow to order the part but it looks like its just worn out a bit thru lack of lube :( so will be ordering a new one and then use a tiny bit of grease on it before i fit it :)

Thank you again for your help on this one.
Xantia Mk2 2.1TD SX
Xantia Mk2 1.9td LX(99v)
C2 1.4 Furio Sensodrive
Toyota Auris 1.4D-4D EMMT

citronut
Over 2k
Posts: 2781
Joined: Wed Oct 31, 2007 7:55 am
Location: EAST SUSSEX UK

Post by citronut » Sat Dec 01, 2007 9:57 pm

sounds like its just the linkage partly siezed, the hight coprectors them selfs give very little trouble
regards malcolm
curent ride
K reg BX 17TD TZD est
also own
K reg D special

no longer have
H reg CX saffari 2.5 TRI (now gone to Malaysia)
R reg xantia 1.9TD est (gone to meet its maker)