Fuel system problem

BX Tech talk
mrmrwray
New Member
Posts: 16
Joined: Wed Jul 06, 2005 7:01 pm
Location: Middleton, Manchester

Fuel system problem

Post by mrmrwray » Sun Feb 26, 2006 9:27 pm

currently struggling with diagnosis of unknown fuel system problem
I have a bx17 tzd non turbo h reg
when the fuel tank is completely full, the engine runs smoothly, the idle is fine and acceleration is fine.
However once down to 3/4 tank or less i experience problems with running which gradually increase the less fuel is in the tank.
when idling the engine cuts out randomly and can be heard to struggle.
power is not consistent when accelerating
power is signigicantly reduced when going uphill as are the random cutting out problems

So far i have taken out and checked the pick up pipes, changed the fuel filter, put some diesel addative in the tank to clean the injectors, checked the fuel pipes for leaks and changed the leak off pipes.
I am going to nip to vanny's where we are going to blow out the fuel pipes and hopefully the pump.

Has anyone had this problem before? Anyone any ideas/suggestions?
In Billy's old diesel and still going strong!

User avatar
sleepy0905
1K Away
1K Away
Posts: 1394
Joined: Thu Aug 25, 2005 9:23 am
Location: Birchwood, Lincoln

Post by sleepy0905 » Sun Feb 26, 2006 9:57 pm

Had this once on a petrol car try checking the vent pipe for the tank mine was a blocked vent and on opening the filler you heard a his of air as you released the vacume if you drove the car with the filler cap off then there was no problem. :D
2014 Citroen C4 1.6 eHDI Selection Special edition 115Bhp

jeremy
Over 2k
Posts: 2112
Joined: Fri Jul 01, 2005 2:58 am
Location: Hampshire UK

Post by jeremy » Sun Feb 26, 2006 10:43 pm

I agree with Sleepy - it may be the cause. If its not it may be worth replacing the last pipe to the injection pump with clear plastic to see what's happening.

jeremy

User avatar
ken newbold
Over 2k
Posts: 4408
Joined: Sun Aug 14, 2005 10:53 pm
x 5

Post by ken newbold » Sun Feb 26, 2006 11:17 pm

I'd try lifting the back seat up and getting out the gauze filter in the tank. It could be blocking but if is not you've eliminated one possiblity at no cost.

I found this problem once on a 17tzd, turned out the filter was caked in, almost a wax substance which prevented the fuel getting through once the tank started to get anywhere near half full.

User avatar
Terry Brooks
BXpert
BXpert
Posts: 402
Joined: Mon Nov 21, 2005 8:53 pm
Location: No 1 at the end of the bar .....@Milton Arms,Rotherham

Post by Terry Brooks » Mon Feb 27, 2006 1:43 am

I've got similar probs with my 1.7 Turbo .....poor starting?,erratic tickover?....I've no idea whats causing it but I have found that by pressurising the fuel system with the primer the problem disappears ....I suspect air getting into the system somewhere....I will get 'round to sorting it out when the weather warms up a bit.....but in the meantime try parking the car facing downhill if the tank aint full,seems it stops air leaks.
HTH
Terry
Dont let the 2CV fool you,I'm not a hippy,I like violence