Indicator stalk problem.

BX Tech talk
User avatar
cavmad
Keeper of the site Goat
Posts: 7858
Joined: Fri May 20, 2005 9:13 am

Indicator stalk problem.

Post by cavmad » Sun Sep 11, 2005 7:03 pm

Just replaced the indicator stalk on my BX estate as the old one was playing up. Indicators would only work when they wanted and jiggling the stalk about got them to go, though it`s bloody annoying. Replaced the stalk with a spare and guess what? It`s started to do it again! Any ideas please?
Vauxhall apologist.

User avatar
Vanny
Merseyside resident
Merseyside resident
Posts: 3422
Joined: Tue May 17, 2005 11:48 pm
Location: BX Pub
My Cars: BX 16v Ph2
x 11

Post by Vanny » Sun Sep 11, 2005 9:12 pm

all the indicators run through the hazards switch, i reckon thats what will be at fault! Only thing is it s bloody fragile bugger so go slowly and carefully!

User avatar
sleepy0905
1K Away
1K Away
Posts: 1394
Joined: Thu Aug 25, 2005 9:23 am
Location: Birchwood, Lincoln

Post by sleepy0905 » Sun Sep 11, 2005 9:33 pm

Hi I also had same problem replaced the stalk which didnt fix it in the end all my indicators failed so after a frantic afternoon looking at bulbs and fuses I ended up replacing the hazard switch which cured the problem :)
2014 Citroen C4 1.6 eHDI Selection Special edition 115Bhp

User avatar
cavmad
Keeper of the site Goat
Posts: 7858
Joined: Fri May 20, 2005 9:13 am

Post by cavmad » Sun Sep 11, 2005 9:40 pm

Cheers fellas, after the day I`ve had that`s good news.
Vauxhall apologist.

User avatar
sleepy0905
1K Away
1K Away
Posts: 1394
Joined: Thu Aug 25, 2005 9:23 am
Location: Birchwood, Lincoln

Post by sleepy0905 » Sun Sep 11, 2005 9:54 pm

The easy option is to replace the switch dont try and take it to bits I did and ended up with bits of brass and springs everywhere and the plastic clips snapped as well :oops:
2014 Citroen C4 1.6 eHDI Selection Special edition 115Bhp

Stewart (oily!)
1K Away
1K Away
Posts: 1604
Joined: Wed May 18, 2005 6:23 pm
Location: North Wales

Post by Stewart (oily!) » Mon Sep 12, 2005 4:43 pm

Many electrical mysteries have been solved by adding an extra earth cable between the engine and body, I generally fit one when I get a new BX
Stewart
TZD 19 TD one of the few
Xantia Td estate, going soft

User avatar
cavmad
Keeper of the site Goat
Posts: 7858
Joined: Fri May 20, 2005 9:13 am

Post by cavmad » Mon Sep 12, 2005 5:38 pm

Thanks Stewart, anywhere in particular on the engine or just somewhere with a suitable hole?
Vauxhall apologist.

User avatar
AndersDK
BXpert
BXpert
Posts: 537
Joined: Sat Jul 23, 2005 4:41 pm
Location: Denmark West

Post by AndersDK » Mon Sep 12, 2005 6:02 pm

Its the braided strap from battery clamp bracket bolt to the gearbox earthing bolt that is meant to do this.
Often you'll find some green remnants of the strap under both boltheads.
Get a ready made (black) battery cable some 1ft long, with cable eyes 8mm hole both ends.
C U / Anders - '90red16riBreak - '91GrisDolment16meteor - Project'88red19trsBreak
dead cars : '89white 16RS - '89antrasitTRDturboEst - '90white19triBreak

User avatar
DLM
Our Trim Guru
Posts: 1569
Joined: Mon May 16, 2005 6:41 pm
Location: Gosport, Hampshire, UK
My Cars: None since the last BX.
x 1

Post by DLM » Mon Sep 12, 2005 6:41 pm

I went though just about all of the above with an indicators/hazards problem, and eventually called in a 'tron (Tom). In the end it proved to be due to the multistrand ribbon cable running front-rear, which had become chafed due to some of my more enthusiastic boot loading-up and was spontaneously earthing.
Relying on two wheels and musclepower since the last BX (or any car) had to go.

User avatar
cavmad
Keeper of the site Goat
Posts: 7858
Joined: Fri May 20, 2005 9:13 am

Post by cavmad » Mon Sep 12, 2005 6:42 pm

Thanks Anders. I have been out and replaced the hazard switch just now (thank God for the mountain of spares I got with the car!). As I was fitting it I tested it and it worked great. Put it into the dashboard and I bet I don`t have to tell you what happened?
You`ve guessed it, naff all. Took it out, put it back in (more carefully this time!) and it`s working now.
The acid test will come tonight when I take `er indoors to work........
Vauxhall apologist.

User avatar
cavmad
Keeper of the site Goat
Posts: 7858
Joined: Fri May 20, 2005 9:13 am

Post by cavmad » Mon Sep 12, 2005 8:48 pm

B*ll*cks, guess what? Packed up again and frequent messing about with the hazard switch hasn`t done much. Had a quick look at the earthing strap which LOOKS o.k but I`ll get the one off my scrap Maestro and have two on the BX. I know the o/s/r light unit was playing up as Vanny gave it a quick bang to get it to work when we went to look at the car and it`s thought that the bulb holders and/or earth maybe dodgy.
I`m trying to keep my patience at the moment but can`t do without indicators!
Vauxhall apologist.

User avatar
Vanny
Merseyside resident
Merseyside resident
Posts: 3422
Joined: Tue May 17, 2005 11:48 pm
Location: BX Pub
My Cars: BX 16v Ph2
x 11

Post by Vanny » Tue Sep 13, 2005 10:45 pm

with the 'fonz' method having been used on the O/S ligth it will just be corrosion on the bulb! Might be worth pulling them all out and having a check?

User avatar
cavmad
Keeper of the site Goat
Posts: 7858
Joined: Fri May 20, 2005 9:13 am

Post by cavmad » Wed Sep 14, 2005 11:06 am

DLM wrote:I went though just about all of the above with an indicators/hazards problem, and eventually called in a 'tron (Tom). In the end it proved to be due to the multistrand ribbon cable running front-rear, which had become chafed due to some of my more enthusiastic boot loading-up and was spontaneously earthing.
Is that a replacement job or can I fabricate some sort of bodge would you know? Cheers.
Vauxhall apologist.

User avatar
AndersDK
BXpert
BXpert
Posts: 537
Joined: Sat Jul 23, 2005 4:41 pm
Location: Denmark West

Post by AndersDK » Wed Sep 14, 2005 6:18 pm

Lift the carpets and follow multiribbon cable on LHS of the floor. Quite often it is chafed right under the seat squab.
Or the multiplug is a green-corroded mess behind LHS rearlamp cluster :roll:
C U / Anders - '90red16riBreak - '91GrisDolment16meteor - Project'88red19trsBreak
dead cars : '89white 16RS - '89antrasitTRDturboEst - '90white19triBreak

User avatar
cavmad
Keeper of the site Goat
Posts: 7858
Joined: Fri May 20, 2005 9:13 am

Post by cavmad » Thu Sep 15, 2005 6:42 am

Thanks, I will be trying that when I get 5 minutes.
Vauxhall apologist.