Rear demister

BX Tech talk
User avatar
Philip Chidlow
Over 2k
Posts: 11548
Joined: Fri Oct 07, 2005 1:08 pm
Location: Chelmsford, Essex
x 11

Rear demister

Post by Philip Chidlow » Sun Nov 06, 2005 2:56 pm

In one of my BXs the window demister has stopped working. Well, doing what it's supposed to do. I think this happened when the console switch bulb went. Could it be the fault of the switch or a fuse, or what? I can't see any evidence of damage to the element and the connector's fine...

Phil
• COMING SOON... 1992 Citroen BX TZD Turbo Hurricane
• COMING SOON... 1998 Citroen Xantia 2.0 16v auto Exclusive
• Xsara Picasso 1.6 16v
and some Ford tat lol

jeremy
Over 2k
Posts: 2112
Joined: Fri Jul 01, 2005 2:58 am
Location: Hampshire UK

Post by jeremy » Sun Nov 06, 2005 3:54 pm

If you have a meter disconnect one side of the element and see if the element still conducts. Its unlikely that all the bits printed on the screen have gone but this would settle the matter.

From the sound of it unless a fuse has gone you will have to remove the switch and investigate. First establish if there is power getting to it with the ignition switched on.

Does the light function dimly with the sidelights as it should? - If it does then the earth is probably OK.

I'm not at home at the moment and so can't check but there could be a relay in the circuit in which case locating it and testing both it and the availability of power at its socket is probably a good starting point.

jeremy

User avatar
Philip Chidlow
Over 2k
Posts: 11548
Joined: Fri Oct 07, 2005 1:08 pm
Location: Chelmsford, Essex
x 11

Post by Philip Chidlow » Sun Nov 06, 2005 4:04 pm

Thanks for the advice - when it stops raining - and gets a bit colder (so I can see if it works!) - I'll get investigating. As for the switch it glows dimly but when I press it the light goes out rather than brighten. Either way, it doesn't seem to demist, pressed or not...

Again, many thanks
• COMING SOON... 1992 Citroen BX TZD Turbo Hurricane
• COMING SOON... 1998 Citroen Xantia 2.0 16v auto Exclusive
• Xsara Picasso 1.6 16v
and some Ford tat lol

User avatar
(CZ)enda
Confirmed BX'er
Posts: 39
Joined: Sun Nov 06, 2005 11:15 pm
Location: Pilsen, CZ

Post by (CZ)enda » Sun Nov 06, 2005 11:19 pm

If you want to be on the safe side, you can check the resistance of the printed circuit. It is supposed to be some 700 ohms.

tom
Citroen Sorceror
Posts: 1239
Joined: Fri May 20, 2005 8:51 pm
Location: straddling the channel

Post by tom » Sat Nov 19, 2005 12:40 pm

Read this month's Ramblings where you will find a how to debug the heated rear window section.