ABS fault. Help needed please!

BX Tech talk
User avatar
deltic
BXpert
BXpert
Posts: 612
Joined: Tue Jan 25, 2011 10:48 pm
x 11

Re: ABS fault. Help needed please!

Post by deltic » Sun Dec 20, 2015 10:48 pm

Hi Ken,

Here are a couple of images of a rear sensor:

https://bartebben.com/dailySQL/Images/i ... 0b6c5z.jpg

https://bartebben.com/parts/citroen/bx/ ... 37913.html

The front sensors have an additional screw at 90 degrees to the where the mounting bolt passes through see page 8 of:

http://web.archive.org/web/200502240848 ... es/abs.pdf

Thanks
1991 BX GTi Auto, grey, 133,000 miles (2015 & 2017 Citroen Classic Challenge veteran)
2006 C4 VTR+ 2.0 Coupé, silver, 60,000 miles

User avatar
deltic
BXpert
BXpert
Posts: 612
Joined: Tue Jan 25, 2011 10:48 pm
x 11

Re: ABS fault. Help needed please!

Post by deltic » Sun Dec 20, 2015 10:50 pm

Jaba wrote:
deltic wrote:
Yes and no! We all learn the hard way sometime, but as the rear sensor was already broken and I unknowingly had the wrong replacement I was always going to need the expense of another sensor, just I didn't know. At least now it should be easy to fit the replacement.

Famous last words.
Well yes and no..... the sensor may well have been ok it is always best to just cut the lead near the sensor then measure its resistance, if it reads normally you can then solder on or even use a terminal block to connect some screen cable back to the seat connector.

N.B. You will need to use a round file to enlarge the locating hole on the hub to allow the replacement sensor to slide in easily without further damage.
Yes I'll stick to gardening and photography in future... That said I did take a file to the locating hole in the hope that the front sensor might fit, however I suspect it has a slightly wider diameter.
1991 BX GTi Auto, grey, 133,000 miles (2015 & 2017 Citroen Classic Challenge veteran)
2006 C4 VTR+ 2.0 Coupé, silver, 60,000 miles