Ive got a TZD today

Anything about BXs
User avatar
Way2go
Over 2k
Posts: 7279
Joined: Fri Jan 13, 2006 3:15 pm
Location: RCoBerkshire
x 2

Post by Way2go »

& anyway you are the Bandit! :lol:
1991 BX19GTi Auto

User avatar
cavmad
Keeper of the site Goat
Posts: 7857
Joined: Fri May 20, 2005 9:13 am

Post by cavmad »

Something about a BX iirc :lol:
Vauxhall apologist.

User avatar
MULLEY
Over 2k
Posts: 8406
Joined: Thu Jun 22, 2006 11:10 pm
Location: Derbyshire
x 8

Post by MULLEY »

I remember even after 10 pages worth, mind u i did post this little beauty....

I decided to use this as my TZD (& sometimes Gti) blog, of all things that i have done on the cars & what new troubles i have stumbled across.....

User avatar
MULLEY
Over 2k
Posts: 8406
Joined: Thu Jun 22, 2006 11:10 pm
Location: Derbyshire
x 8

Post by MULLEY »

Er new problem has reared its head, it needed 3 attempts of the ignition switch to get the glow plug light to come on & then it started ok, does this signal new glowplugs? or something else? this is the 1st time its done that & it happened when i was coming home from work today (its in a dry basement garage at work).... hoping someone can shed some light, perhaps it was a one off????

User avatar
BX Bandit
Backslash Bandit
Posts: 2588
Joined: Thu Aug 31, 2006 7:46 am
Location: Home
My Cars: Cars
x 1

Post by BX Bandit »

The dash light should come on irrespective of the glowplug condition..It is more likely to be a dirty contact - probably on the connections to the blue glowplug relay box fitted in the engine bay by the front n/s wing. Clean the contacts up with some emery cloth or wet and dry and see hot it goes. If you take the relay box off (only one bolt) you may as well open it and clean the relay contacts aswell...
1990 BX 16V Platinum Grey
1990 BX TGD White
1960 Morris Minor Clarondon Grey
1971 Triumph 2000 Auto Valencia Blue

User avatar
MULLEY
Over 2k
Posts: 8406
Joined: Thu Jun 22, 2006 11:10 pm
Location: Derbyshire
x 8

Post by MULLEY »

Cheers for that Bandit, will have a look when it stops raining (that should be May next year then).... lol

jeremy
Over 2k
Posts: 2112
Joined: Fri Jul 01, 2005 2:58 am
Location: Hampshire UK

Post by jeremy »

I bet its the ignition switch failing.

tim leech

Post by tim leech »

Does the glow plug solonoid click on when you turn it? I remember on that car the soloboid was quite loud.

User avatar
MULLEY
Over 2k
Posts: 8406
Joined: Thu Jun 22, 2006 11:10 pm
Location: Derbyshire
x 8

Post by MULLEY »

Er, will have to double check the solenoid click sound tomorrow & report back. I hope its not the ignition.....

User avatar
ken newbold
Over 2k
Posts: 4408
Joined: Sun Aug 14, 2005 10:53 pm
x 5

Post by ken newbold »

I'll go with Jeremy,

easy fix if it is. :D
They think it's all over, it is now!

User avatar
cavmad
Keeper of the site Goat
Posts: 7857
Joined: Fri May 20, 2005 9:13 am

Post by cavmad »

So easy in fact that even I managed to change one once!
Vauxhall apologist.

tim leech

Post by tim leech »

:D Theres hope for me yet!

User avatar
cavmad
Keeper of the site Goat
Posts: 7857
Joined: Fri May 20, 2005 9:13 am

Post by cavmad »

:lol: :lol: :lol: :lol: There`s hope for anybody Tim if I can do it :D
Vauxhall apologist.

tim leech

Post by tim leech »

:shock: Oi!

User avatar
MULLEY
Over 2k
Posts: 8406
Joined: Thu Jun 22, 2006 11:10 pm
Location: Derbyshire
x 8

Post by MULLEY »

Car was spot on today when starting her up, not sure i even heard the solenoid click (i might be going deaf??) so perhaps an intermittent fault or a one off?? i guess over time i will find out. Hopefully when seeing Ken this wknd, i may be able to have a look into this a bit more.