Annoying fast ticking/static-like sound from the instrument cluster

BX Tech talk
User avatar
Jugostran
BXpert
Posts: 185
Joined: Fri Sep 10, 2021 6:22 pm
Location: Osijek, Croatia
My Cars: 1989 Cimos-Citroën BX 16 TRS
2007 BMW 318D (the "company car")
x 43

Annoying fast ticking/static-like sound from the instrument cluster

Post by Jugostran »

Hey all.
I've been having an issue with my BX that has finally gotten on top of my nerves. Namely there is this annoying ticking/static noise coming from the instrument cluster. I am pretty sure it's the speedometer cable.
I'd like to make it go away because the car is essentially impossible to drive as is. Imagine an old out of tune CRT TV in the cabin with you at all times. Not ideal.
Anyone have any tips or tricks, or had this issue before? Asking because I could theoretically install another speedometer cable, but it'll be a used one, so it may have the same issue. I'm just curious as to where the noise comes from and can it be silenced with lubrication/cleaning.
Thank you!
Proudly daily driving a 1989 BX 16 TRS since 2021

Image
User avatar
Dave_16v
BXpert
Posts: 209
Joined: Fri Aug 25, 2017 10:20 pm
Location: Yorkshire
My Cars: BX 16 Valve Ph 2 Current
BX 16 valve Ph 1 past
BX Gti past
BX Gti Auto past
ZX Volcane keeping others going
x 61

Re: Annoying fast ticking/static-like sound from the instrument cluster

Post by Dave_16v »

By the sound of it, the needle isn't fluctuating because you likely would have said so. I don't know if your cable is the same as mine in two halfs, I think it might be but either way, they must take the best route from the drive to the speedometer. You could try pushing or pulling it a little from the engine bay to see if it alters but if part of the cable is worn, it will get worse until you fit a different one. Getting some form of lubricant in there may help of course.
Prefer it to the Lamborghini, like Signor Gandini!

Image
User avatar
Jugostran
BXpert
Posts: 185
Joined: Fri Sep 10, 2021 6:22 pm
Location: Osijek, Croatia
My Cars: 1989 Cimos-Citroën BX 16 TRS
2007 BMW 318D (the "company car")
x 43

Re: Annoying fast ticking/static-like sound from the instrument cluster

Post by Jugostran »

Dave_16v wrote: Wed Apr 10, 2024 7:43 pm By the sound of it, the needle isn't fluctuating because you likely would have said so. I don't know if your cable is the same as mine in two halfs, I think it might be but either way, they must take the best route from the drive to the speedometer. You could try pushing or pulling it a little from the engine bay to see if it alters but if part of the cable is worn, it will get worse until you fit a different one. Getting some form of lubricant in there may help of course.
That is correct. It's not fluctuating. Actually, that's not entirely correct. It is, but its really slight and doesn't bother me. The speedometer is accurate enough. The problem is that irritating sound. Mine is two parts, just like yours. I already tried lubricating, but the noise is still there. All the lubricant did was improve the fluctuations (now they are way less noticeable).
Proudly daily driving a 1989 BX 16 TRS since 2021

Image
User avatar
Dave_16v
BXpert
Posts: 209
Joined: Fri Aug 25, 2017 10:20 pm
Location: Yorkshire
My Cars: BX 16 Valve Ph 2 Current
BX 16 valve Ph 1 past
BX Gti past
BX Gti Auto past
ZX Volcane keeping others going
x 61

Re: Annoying fast ticking/static-like sound from the instrument cluster

Post by Dave_16v »

I think a lot of problems are caused by the routing and ensuring the it puts as little stress on the cable as possible, especially towards the point it gets near the binnacle.
Prefer it to the Lamborghini, like Signor Gandini!

Image
User avatar
Jaba
1K Away
Posts: 1907
Joined: Tue Jul 05, 2005 7:54 am
Location: Usually in the garage
My Cars: BX GTi, C3 Auto
x 86

Re: Annoying fast ticking/static-like sound from the instrument cluster

Post by Jaba »

The cables do wear and get noisy and the speedo head can do likewise too. Have you tried disconnecting the cable at the speedo end for diagnosis before fitting a replacement cable.
The Joy of BX with just one Citroën BX to my name now. Will I sing Bye Bye to my GTI or will it be Till death us do part.
User avatar
Jugostran
BXpert
Posts: 185
Joined: Fri Sep 10, 2021 6:22 pm
Location: Osijek, Croatia
My Cars: 1989 Cimos-Citroën BX 16 TRS
2007 BMW 318D (the "company car")
x 43

Re: Annoying fast ticking/static-like sound from the instrument cluster

Post by Jugostran »

Jaba wrote: Wed Apr 10, 2024 10:15 pm The cables do wear and get noisy and the speedo head can do likewise too. Have you tried disconnecting the cable at the speedo end for diagnosis before fitting a replacement cable.
I haven't. Last I checked the section which plugs into the speedo was stuck.
Proudly daily driving a 1989 BX 16 TRS since 2021

Image