Am I getting too involved with this car?

BX Tech talk
User avatar
Oscar
1K Away
Posts: 1091
Joined: Wed May 18, 2005 5:07 pm
Location: Driving a ZX

Am I getting too involved with this car?

Post by Oscar »

Last night I came home, pulled up, turned the lights off and switched the engine off. In between turning the lights off and switching the engine off, it seemed to me that engine revs increased slightly. So I turned the engine back on and tested.

Engine revs definitely drop when the headlights are on, and pick up when they are switched off.

Does this mean anything significant? Should I be worried? Am I simply paying too much attention to what is going on?
(Red BX 1.7TZD ("Well, it is a style icon" - Tom Sheppard)) "Was", Tom, "was"

Brian
BXpert
Posts: 441
Joined: Sun Jan 08, 2006 5:53 pm
Location: Bedfordshire UK

Post by Brian »

Hi Oscar,

Most likely it's the extra load from the alternator compensating for all the current for the lights.

If you have a voltmeter / multimeter, just connect it in the volt range, then switch on all the electrical loads one at a time and moitor the voltage and engine revs..

With a good battery and alternator, and keeping the revs up a little, you should see the volts holding about 13.00 / 13.8 or even 14.00...

Cheers

jeremy
Over 2k
Posts: 2112
Joined: Fri Jul 01, 2005 2:58 am
Location: Hampshire UK

Post by jeremy »

In another post you concede the injectors need cleaning. The injection pump does have a governor section which controls the idle and if the injectors are dirty it may be the engine isn't responding to additional fuel as it should do.

jeremy

User avatar
Oscar
1K Away
Posts: 1091
Joined: Wed May 18, 2005 5:07 pm
Location: Driving a ZX

Post by Oscar »

Jeremy, Brian, thanks for suggestions. I recently turned the revs limiter down slightly too, so that may have something to do with it.

Regards

Oscar
(Red BX 1.7TZD ("Well, it is a style icon" - Tom Sheppard)) "Was", Tom, "was"

Mr B
Northern Moderator
Northern Moderator
Posts: 710
Joined: Mon May 16, 2005 12:32 pm
Location: On a sofa, up the road from Marty!

Post by Mr B »

I'm with Brian, it's the load on the altenator slowing the engine.

User avatar
Way2go
Over 2k
Posts: 7280
Joined: Fri Jan 13, 2006 3:15 pm
Location: RCoBerkshire
x 2

Post by Way2go »

Mr B wrote:I'm with Brian, it's the load on the altenator slowing the engine.
I agree too & suggest if the idle speed is OK with the lights on then you don't have a problem. If the idle speed is too low (maybe hunting) when you switch the lights on then idle speed needs adjusting.

You probably need advice from the other diesel guys on adjustment as the procedure varies with engine types and fitments.
1991 BX19GTi Auto

User avatar
DavidRutherford
BX Digit man!
Posts: 2705
Joined: Wed May 18, 2005 5:07 pm
Location: Placing comments on YouTube.

Post by DavidRutherford »

If the engine idle speed is reacting too much to the engine load, then it may be that the idle speed is relying too much on the accelerator pedal lever rather than the idle speed lever.

To make the engine idle speed more governer controlled, rather than power controlled, wind the engine idle speed up just a little bit with the idle speed adjuster, and then slow it down again by winding the accelerator lever stop back a bit.

Only do this a TINY bit at a time (like 25rpm) and then road test the engine, as if you do it too much, the anti-stall speed of the engine will be too low, and it may start to stall when slowing down (when you dip the clutch to come to a stop)

Doing this also means the engine is less reliant on the wax-capsule cold-idle device, and you can live with a dead one (at £18 for a new one, I can live with a dead one!)
this might be a signature

tim leech

Post by tim leech »

My dads 1991 19TGD had a problem with the alternator, but in this case it was pumping out too much power and kept blowing fuses and bulbs! Took ages tow ork what was up with it!.

User avatar
mnde
Meteor Man
Posts: 1453
Joined: Tue Oct 18, 2005 5:10 pm
Location: Aldershot, Hants
My Cars: 2007 Citroen Xsara Picasso 1.6 16V VTX
1982 Citroen GSA Spécial Estate - gone to a new home
1991 Citroen BX16 TGS Meteor - still out there somewhere!

Post by mnde »

My GSA had an old and tired alternator. The battery light kept coming on while waiting for long periods in traffic... especially if I had the lights and heater blower going. I had to turn up the idle speed to counter this, as eventually the idle would start to get lumpy and it would stall. An AA man proved to me it was the alternator, when he read the charge rate at idle, and it was below what he would expect. (Yes, I'd left my lights on and drained the battery).

Since I fitted a brand new alternator, I've had no probs whatsoever. You shouldn't have to turn up the idle to compensate for a drop in revs due to the extra load imposed by the headlights. It'll mean you're using more fuel... Check the charge put out by the alternator at your normal idling speed (i.e. when the engine's warmed up).

Mark.

User avatar
DavidRutherford
BX Digit man!
Posts: 2705
Joined: Wed May 18, 2005 5:07 pm
Location: Placing comments on YouTube.

Post by DavidRutherford »

mnde wrote:You shouldn't have to turn up the idle to compensate for a drop in revs due to the extra load imposed by the headlights.
Which I wasn't actually advocating... simply altering the mode in which the injection pump controlls the idle speed...

Unless you weren't referring to my post.... In which case I'll shut up!
this might be a signature

User avatar
mnde
Meteor Man
Posts: 1453
Joined: Tue Oct 18, 2005 5:10 pm
Location: Aldershot, Hants
My Cars: 2007 Citroen Xsara Picasso 1.6 16V VTX
1982 Citroen GSA Spécial Estate - gone to a new home
1991 Citroen BX16 TGS Meteor - still out there somewhere!

Post by mnde »

No, I wasn't ;)

Mark.

User avatar
Oscar
1K Away
Posts: 1091
Joined: Wed May 18, 2005 5:07 pm
Location: Driving a ZX

Post by Oscar »

Thanks guys for all the input. I shall observe for a while and then check the alternator. I don't anticipate any problems with battery and alternator (although there's a spare alternator in the cellar "just in case"), I think it's probably just me mucking about with the idle speed.

O
(Red BX 1.7TZD ("Well, it is a style icon" - Tom Sheppard)) "Was", Tom, "was"

User avatar
DavidRutherford
BX Digit man!
Posts: 2705
Joined: Wed May 18, 2005 5:07 pm
Location: Placing comments on YouTube.

Post by DavidRutherford »

Where's the smiley with the Zip across his mouth?

:oops:
this might be a signature

User avatar
Oscar
1K Away
Posts: 1091
Joined: Wed May 18, 2005 5:07 pm
Location: Driving a ZX

Post by Oscar »

David asked "Where's the smiley with the Zip across his mouth?"

He drives a ZX now :D :D
(Red BX 1.7TZD ("Well, it is a style icon" - Tom Sheppard)) "Was", Tom, "was"