Help, crank no start 16v

BX Tech talk
patersom10
BXpert
BXpert
Posts: 327
Joined: Wed Sep 12, 2012 11:46 pm
Location: Warwickshire

Help, crank no start 16v

Post by patersom10 » Mon Apr 21, 2014 1:03 pm

So having put everything back together this weekend after changing my head gasket she won't start. I have replaced spark plugs, coil, there all good. New starter motor and battery.

Getting spark and fuel to rail, could I have damaged the crank sensor? Would this stop injectors?

A bit lost, any advice welcomed.

Put some easy start but all that did was smoke, timing all correct.

Thanks. Matt
93 ZX Volcane TD
03 Xsara VTR - HDI (remapped to 140bhp)

92 BX 16v phase 2 - now sold
93 BX 17TGD - now sold

patersom10
BXpert
BXpert
Posts: 327
Joined: Wed Sep 12, 2012 11:46 pm
Location: Warwickshire

Re: Help, crank no start 16v

Post by patersom10 » Mon Apr 21, 2014 1:16 pm

Had new dizzy cap and rotor
93 ZX Volcane TD
03 Xsara VTR - HDI (remapped to 140bhp)

92 BX 16v phase 2 - now sold
93 BX 17TGD - now sold

User avatar
Kitch
Over 2k
Posts: 6213
Joined: Sun Jul 03, 2005 9:36 pm
Location: Fareham, Hants
x 50

Re: Help, crank no start 16v

Post by Kitch » Mon Apr 21, 2014 7:35 pm

Crank sensor could stop injectors firing at the right times. Download the diagnostics off the 16v forum and get your multimeter out!

patersom10
BXpert
BXpert
Posts: 327
Joined: Wed Sep 12, 2012 11:46 pm
Location: Warwickshire

Re: Help, crank no start 16v

Post by patersom10 » Mon Apr 21, 2014 8:23 pm

Cheers bud, will take a look.

Tax and Mot due in a couple of weeks and with the car on the road outside the house it's panic time !
93 ZX Volcane TD
03 Xsara VTR - HDI (remapped to 140bhp)

92 BX 16v phase 2 - now sold
93 BX 17TGD - now sold

User avatar
mat_fenwick
Moderator
Posts: 7279
Joined: Tue Sep 20, 2005 4:08 pm
Location: North Wales
x 13

Re: Help, crank no start 16v

Post by mat_fenwick » Tue Apr 22, 2014 12:39 am

Kitch wrote:Crank sensor could stop injectors firing at the right times. Download the diagnostics off the 16v forum and get your multimeter out!
Would this matter though? I think it's a batch fired injection system, so the injectors are mostly going to be firing against closed valves anyway. Wonder if lack of crank sensor signal would stop injectors firing at all though? In which case a noid light would be useful.
Image

1993 1.9 TZD Turbo Estate
1996 3.9 V8 Discovery
1993 VW LT35 campervan
1985 Hyundai Stellar V8
2016 Hyundai iLoad

User avatar
Kitch
Over 2k
Posts: 6213
Joined: Sun Jul 03, 2005 9:36 pm
Location: Fareham, Hants
x 50

Re: Help, crank no start 16v

Post by Kitch » Tue Apr 22, 2014 9:05 am

mat_fenwick wrote:
Kitch wrote:Crank sensor could stop injectors firing at the right times. Download the diagnostics off the 16v forum and get your multimeter out!
Would this matter though? I think it's a batch fired injection system, so the injectors are mostly going to be firing against closed valves anyway. Wonder if lack of crank sensor signal would stop injectors firing at all though? In which case a noid light would be useful.
You'd get coughs and splutters I would think, but the injector timing is linked to the ignition timing in the ECU, so if they're both out of kilter it can have an effect.

RobC
BXpert
BXpert
Posts: 420
Joined: Tue Aug 15, 2006 11:15 am
Location: East London
x 7

Re: Help, crank no start 16v

Post by RobC » Tue Apr 22, 2014 10:31 am

Have you checked the earth to the ignition module on the bulkhead? I remember I once had to splice that direct back to the battery because some wires broke. Also the earth point by the battery is a bit dodgy on J-HUF anyway, unless it's been tidied up properly since I owned it...

(edit: just saw you're getting a spark, so ignore that!)
1991 Citroen BX 16v

adamskibx
BXpert
BXpert
Posts: 950
Joined: Fri Jul 22, 2005 9:26 pm

Re: Help, crank no start 16v

Post by adamskibx » Tue Apr 22, 2014 4:00 pm

Even if the injectors could get away with firing at the wrong time, the spark plugs couldn't.

adamskibx
BXpert
BXpert
Posts: 950
Joined: Fri Jul 22, 2005 9:26 pm

Re: Help, crank no start 16v

Post by adamskibx » Tue Apr 22, 2014 4:02 pm

I would get hold of a strobe and paint some timing marks and see if it flashes when it should when trying to start.

patersom10
BXpert
BXpert
Posts: 327
Joined: Wed Sep 12, 2012 11:46 pm
Location: Warwickshire

Re: Help, crank no start 16v

Post by patersom10 » Tue Apr 22, 2014 4:40 pm

http://www.ebay.co.uk/itm/Crank-Sensor- ... 19e94e715d

anyone know the part number for the crank sensor, if its this one attached may as well change it. changed everything else !
93 ZX Volcane TD
03 Xsara VTR - HDI (remapped to 140bhp)

92 BX 16v phase 2 - now sold
93 BX 17TGD - now sold

patersom10
BXpert
BXpert
Posts: 327
Joined: Wed Sep 12, 2012 11:46 pm
Location: Warwickshire

Re: Help, crank no start 16v

Post by patersom10 » Tue Apr 22, 2014 10:05 pm

thinking about getting shipped to rob at chevronics, if he will take it on.

would I even be able to get it on a trailer as its at low?
93 ZX Volcane TD
03 Xsara VTR - HDI (remapped to 140bhp)

92 BX 16v phase 2 - now sold
93 BX 17TGD - now sold

User avatar
Kitch
Over 2k
Posts: 6213
Joined: Sun Jul 03, 2005 9:36 pm
Location: Fareham, Hants
x 50

Re: Help, crank no start 16v

Post by Kitch » Tue Apr 22, 2014 10:40 pm

You can check all this stuff using a multimeter and the pins on the ECU plug. It's actually pretty easy to diagnose problems using the PDFs you can download from the 16v forum.

patersom10
BXpert
BXpert
Posts: 327
Joined: Wed Sep 12, 2012 11:46 pm
Location: Warwickshire

Re: Help, crank no start 16v

Post by patersom10 » Sun May 04, 2014 1:22 pm

Now for sale
93 ZX Volcane TD
03 Xsara VTR - HDI (remapped to 140bhp)

92 BX 16v phase 2 - now sold
93 BX 17TGD - now sold

patersom10
BXpert
BXpert
Posts: 327
Joined: Wed Sep 12, 2012 11:46 pm
Location: Warwickshire

Re: Help, crank no start 16v

Post by patersom10 » Sat May 24, 2014 12:12 pm

So having not sold my 16v, I have been tinkering with it.

Joy ! Managed to get it started today, unfortunately it then decided after 1 min of running to dump all its oil and coolant.

Have found the source of the coolant dump (cracked hose behind block)

However the oil is a bit strange, the oil filler cap blew off causing the car to be decorated a lovely light brown colour. I presume it's high pressure.

Any ideas ?
93 ZX Volcane TD
03 Xsara VTR - HDI (remapped to 140bhp)

92 BX 16v phase 2 - now sold
93 BX 17TGD - now sold

User avatar
Way2go
Over 2k
Posts: 7279
Joined: Fri Jan 13, 2006 3:15 pm
Location: RCoBerkshire
x 2

Re: Help, crank no start 16v

Post by Way2go » Sat May 24, 2014 1:53 pm

patersom10 wrote: However the oil is a bit strange, the oil filler cap blew off causing the car to be decorated a lovely light brown colour. I presume it's high pressure.

Any ideas ?
Could be that you detonated the petrol/petrol vapour accumulated in the sump following all the extensive petrol metering of the injectors without a previous start? :?
1991 BX19GTi Auto