Wanted

Buy or sell parts etc. Please put 'Wanted' in the title if it is a request for parts.
rutter123
Over 2k
Posts: 2501
Joined: Sun Sep 02, 2012 9:54 pm
Location: South Lincs
My Cars: 65 Peugeot Boxer van 160k
Ven red tzd turbo 294k it will live again
Nissan Micra K13 the wife's run around
x 99

Wanted

Post by rutter123 »

Rev counter pick up sensor 3 pole for 1990 t/d (the one at the back of the gearbox) or a point in the right direction of a supplier or even a part number. Is it the same as fitted to a petrol engine?
90 BX Tzd turbo 294k SORN undergoing major surgery
90 BX Tzd turbo estate 46k awaiting surgery
65 Peugeot Boxer Van the new workhorse
52 Toyota Rav4 180k Bulletproof Jap reliability

Richb
Confirmed BX'er
Posts: 90
Joined: Wed May 27, 2015 4:23 pm
Location: Selby
x 1

Re: Wanted

Post by Richb »

If you send me a pm with a vin no i can look on the citroen system for a part no if you want.
2001 Peugeot 206 2.0 Hdi
1999 Peugeot Expert Van
1993 Citroen BX 1.9TXD
1992 Citroen BX 1.9TXD
1980 Triumph TR8
1972 Triumph Stag
1967 Triumph GT6

User avatar
ken newbold
Over 2k
Posts: 4408
Joined: Sun Aug 14, 2005 10:53 pm
x 5

Re: Wanted

Post by ken newbold »

I know there's one in the garage, I'll need to test it, if it's ok it's yours for the postage. £
They think it's all over, it is now!

rutter123
Over 2k
Posts: 2501
Joined: Sun Sep 02, 2012 9:54 pm
Location: South Lincs
My Cars: 65 Peugeot Boxer van 160k
Ven red tzd turbo 294k it will live again
Nissan Micra K13 the wife's run around
x 99

Re: Wanted

Post by rutter123 »

Hi Ken, that would be good, mine works for a few mins then stops, its been doing this for a few months now im hoping it is the pick up not the tacho head let me know when you find it and I will pm you post details, thanks.
90 BX Tzd turbo 294k SORN undergoing major surgery
90 BX Tzd turbo estate 46k awaiting surgery
65 Peugeot Boxer Van the new workhorse
52 Toyota Rav4 180k Bulletproof Jap reliability

User avatar
ken newbold
Over 2k
Posts: 4408
Joined: Sun Aug 14, 2005 10:53 pm
x 5

Re: Wanted

Post by ken newbold »

Ok, been in garage and found it, tests ok, but before we go any further, a couple of things to try.

1 Make sure your connections are good in the brown plug.
2 Make sure your exixting sensor is pushed fully home in it's mounting. From memory, I think they will touch the flywheel, so just edge it back a little. Had this fault myself once and re-seating it cured the problem.

If you've already done that, send me your address and I'll post this on.
They think it's all over, it is now!