TZD Non-Start

BX Tech talk
Dominic
Confirmed BX'er
Posts: 42
Joined: Wed May 23, 2012 1:59 pm

TZD Non-Start

Post by Dominic » Sun Feb 21, 2016 6:06 pm

Having not used her for 4 months, I changed the fuel filter and she now won't even try to start. Assuming air ingress at the filter, I took the new filter assembly apart again, and lo and behold, the filter is completely dry! Is there a lift pump in the tank I should be looking for?
Dom
91 TZD
02 Picasso HDI
'12 DS5
83 Moto Morini 500
70 Fiat 850 Spider
Anything that turns money into noise...

User avatar
Tim Leech
Over 2k
Posts: 15199
Joined: Tue Apr 15, 2008 11:12 am
Location: Burton on Trent
My Cars: 1963 VW BEETLE 1200 KGJ413A
1972 Morris Marina 1.8 SDL BFA720L
1979 Rover SD1 3.5 V8-S TSL 982
1980 Morris Marina 1.7HL DBV468W
1985 CITROEN BX 19GT C1TBX
1991 CITROEN BX 19TZI AUTO A/C BXi 19
1994 CITROEN XANTIA 1.8 SXi M908HRY
2002 Rover 75 CDT Connossieur SE Nav Auto R40TSL
2003 Rover 25 1.6i XL L33CHT
x 68

Re: TZD Non-Start

Post by Tim Leech » Sun Feb 21, 2016 6:11 pm

You need to prime it with the primer, round black button on top of the fuel filter housing or an inline hand pump.

Give it a fair few squeezes to get fuel up to the pump.
1963 VW BEETLE 1200
1985 BX 19GT Mk1
1991 BX 19TZI Auto A/C
1994 Xantia 1.8i SX
1972 Morris Marina 1.8 SDL
1979 Rover SD1 V8-S
1980 Morris Marina 1.7HL
2002 Rover 75 CDTi Connossieur SE AUTO Nav
2003 Rover 25 1.6i XL 5 DR

Dominic
Confirmed BX'er
Posts: 42
Joined: Wed May 23, 2012 1:59 pm

Re: TZD Non-Start

Post by Dominic » Mon Feb 22, 2016 7:36 pm

Sorry, I described that badly. On the first attempt, I did the usual - button pressing and all - no action - a bit of smoke from the exhaust, so something's trying to ignite - just not very hard. On the subsequent attempt, I turned on the ignition without attaching the fuel input pipes to the filter expecting to see a pumped flow of diesel, but nothing. Is there not a lift pump in the tank? If there is, it ain't working, and if there ain't I've got another problem - possibly stop solenoid.
Dom
91 TZD
02 Picasso HDI
'12 DS5
83 Moto Morini 500
70 Fiat 850 Spider
Anything that turns money into noise...

User avatar
mijfife
Confirmed BX'er
Posts: 61
Joined: Wed Jul 15, 2015 4:21 pm
Location: Rosyth, Fife, Scotland
x 1

Re: TZD Non-Start

Post by mijfife » Mon Feb 22, 2016 8:22 pm

I don't think there is a lift pump at the tank end, it's a bit too old school for that. Mine can be a bit of a sod to restart after changing the filter but I keep priming it after each attempt with the black button and it usually fires up okay after a couple of attempts.
Another thought is that you might have a blockage in the fuel line from the tank. I'd remove the filler cap and then try to blow back through the feed pipe with some compressed air and listen for it bubbling in the tank.

Regards, Jim
1991 BX TZD Hatchback, biodiesel powered :D
2007 Peugeot Partner 1.6HDi - everyday work horse, totally reliable but so dull :roll: 60k miles on my homemade biodiesel so mega cheap to run!
1967 Singer Chamois Coupe - owned since 1998, fully restored by myself - love it.
1991 Kawasaki GPz900r - owned since 2004, awaiting light restoration & a bit of TLC.
2002 Triumph Daytona 955i - bought in 2014 so that I could take Kawasaki off the road to restore - that's my excuse anyway :lol:

User avatar
Tim Leech
Over 2k
Posts: 15199
Joined: Tue Apr 15, 2008 11:12 am
Location: Burton on Trent
My Cars: 1963 VW BEETLE 1200 KGJ413A
1972 Morris Marina 1.8 SDL BFA720L
1979 Rover SD1 3.5 V8-S TSL 982
1980 Morris Marina 1.7HL DBV468W
1985 CITROEN BX 19GT C1TBX
1991 CITROEN BX 19TZI AUTO A/C BXi 19
1994 CITROEN XANTIA 1.8 SXi M908HRY
2002 Rover 75 CDT Connossieur SE Nav Auto R40TSL
2003 Rover 25 1.6i XL L33CHT
x 68

Re: TZD Non-Start

Post by Tim Leech » Tue Feb 23, 2016 8:42 am

No lift pump it's all sucked through from the fuel pump on the block. Just keep pumping! Sounds like you have air in the system.
1963 VW BEETLE 1200
1985 BX 19GT Mk1
1991 BX 19TZI Auto A/C
1994 Xantia 1.8i SX
1972 Morris Marina 1.8 SDL
1979 Rover SD1 V8-S
1980 Morris Marina 1.7HL
2002 Rover 75 CDTi Connossieur SE AUTO Nav
2003 Rover 25 1.6i XL 5 DR

Guest

Re: TZD Non-Start

Post by Guest » Tue Feb 23, 2016 1:29 pm

On my TZD there there is a fuel primer shaped like a mini rugby ball on the top left beside the drivers side sphere and I assume yours is the same, keep squeezing it until you feel some resistance then bobs your uncle! It may take a bit if there's no fuel in the reservoir

User avatar
Russ
Confirmed BX'er
Posts: 46
Joined: Sun Jul 15, 2012 11:53 am
x 2

Re: TZD Non-Start

Post by Russ » Tue Feb 23, 2016 1:29 pm

On my TZD there there is a fuel primer shaped like a mini rugby ball on the top left beside the drivers side sphere and I assume yours is the same, keep squeezing it until you feel some resistance then bobs your uncle! It may take a bit if there's no fuel in the reservoir

User avatar
JayW
1K Away
1K Away
Posts: 1590
Joined: Thu Dec 07, 2006 6:40 pm
Location: Now listen here you mullet...
x 13

Re: TZD Non-Start

Post by JayW » Tue Feb 23, 2016 7:04 pm

You won't see fuel flow from the unattached pipes as the fuel is PULLED by the main HP pump through the filter and disconnecting the pipes will just have it sucking air.

Put it all back together, prime it, then crack off each of the injector unions a turn (17mm). Crank it over and as each union starts to spit diesel, tighten them. Once there's 3 bled it'll run while you tighten the 4th.

That said, if you have an air leak, nothing will work.
I have zero patience for your tedium.