Wiring to coil - BX19 TRS 1989 - and HP pump priming

BX Tech talk
User avatar
Mark.T
Confirmed BX'er
Posts: 47
Joined: Sat Jun 02, 2007 12:19 pm
Location: Melbourne, Australia
x 2

Wiring to coil - BX19 TRS 1989 - and HP pump priming

Post by Mark.T » Mon Sep 05, 2016 2:59 pm

Hi

I've just reparied and re-installed the engine wiring looms on a BX 19 that I've been trying to get back on the road for some time. I'm glad to say that today I at least got the engine running - it started second time which I was pleased with after four years gathering dust... But when I connected the coil wiring (its ignition sysem has the squat type coil with 4-pin connector, and ignition module on the side of the distributor) I noticed one of the wires has nothing I can see to connect to... the left hand wire from pin 4 in the photo below.

Does anyone know what this might connect to - or is it for the test port that my car doesn't have? the only thing just about in reach is one of the carb. solenoids, but this is already powered. Having this wire "loose" hasn't stopped the engine running though.

I've had a look at various wiring diagams I can find, but none of these seem to quite match my car - most have the test socket mentioned above...

Ignition coil connector
Image

Also, I've not been able to get the HP pump primed. I connected a funnel full of LHM to the pump input hose, but none of this was taken by the pump. the hose does dip down a bit before reaching the pump - so possibly there is some air trapped - do I need to disconect the hose form the securing clamp and strighten it out to get LHM into the pump? The pump was working well last time the car ran, and when I had the pump onthe bench it kept spurting LHM every time I moved the pully.

Cheers
Mark T.
Melbourne, Australia
BX16 TRS Auto (Series 1)
BX19 TRS (Series 2)
C3 Pluriel

rutter123
Over 2k
Posts: 2173
Joined: Sun Sep 02, 2012 9:54 pm
Location: South Lincs
x 52

Re: Wiring to coil - BX19 TRS 1989 - and HP pump priming

Post by rutter123 » Mon Sep 05, 2016 4:21 pm

This appears to be the same/similar coil i had fitted on my gti, the pins 3&4 are common to each other and as on the gti pin 4 did not connect to anything. As for priming the pump using a straight bit of hose direct onto the pump with a funnel full of LHM should do the job, it may help if you undo the bleed screw on the pressure regulator (12mm head) half a turn or so, sometimes this helps to expel any air in the system, run it for 60-90secs then do it up see how that goes. Failing that some up and down of the hi/lo lever may help.
90 BX Tzd turbo 294k SORN undergoing major surgery
90 BX Tzd turbo estate 46k awaiting surgery
65 Peugeot Boxer Van the new workhorse
52 Toyota Rav4 180k Bulletproof Jap reliability

User avatar
Mark.T
Confirmed BX'er
Posts: 47
Joined: Sat Jun 02, 2007 12:19 pm
Location: Melbourne, Australia
x 2

Re: Wiring to coil - BX19 TRS 1989 - and HP pump priming

Post by Mark.T » Tue Sep 06, 2016 2:36 pm

Thanks for the advice. The unconnected wire didn't seem to stop the enigine running... I wonder, does it provide any useful diagnostic info to a voltmeter or scope?..

Regarding the HP pump, I loosened the supply tube from its bracket (on alternator supoort) so that as you suggested I could hold it "straight up" and gradually poured LHM through a funnel while cranking the engine and this time the pump did take LHM. Must have been some air trapped before. Reconnected the pump to reservoir and restarted the engine with the pressure regulator "open" as suggested for about a minute. On closing the pressure regullator valve the system pressureised and the rear end lifted after about 30 seconds - with no leaks anywhere to be seen! After checking the clutch, brake and steering funnction I finally moved it out of the garage, after four years up on stands. Will give it a good clean tomorrow! Maybe post some photos in the next few days too.

Regards
Mark T.
Melbourne, Australia
BX16 TRS Auto (Series 1)
BX19 TRS (Series 2)
C3 Pluriel

rutter123
Over 2k
Posts: 2173
Joined: Sun Sep 02, 2012 9:54 pm
Location: South Lincs
x 52

Re: Wiring to coil - BX19 TRS 1989 - and HP pump priming

Post by rutter123 » Tue Sep 06, 2016 6:07 pm

Good job.
90 BX Tzd turbo 294k SORN undergoing major surgery
90 BX Tzd turbo estate 46k awaiting surgery
65 Peugeot Boxer Van the new workhorse
52 Toyota Rav4 180k Bulletproof Jap reliability

User avatar
Tim Leech
Over 2k
Posts: 15205
Joined: Tue Apr 15, 2008 11:12 am
Location: Burton on Trent
My Cars: 1958 ROVER P4 90 UWP 84
1963 VW BEETLE 1200 KGJ413A
1972 Morris Marina 1.8 SDL BFA720L
1979 Rover SD1 3.5 V8-S TSL 982
1980 Morris Marina 1.7HL DBV468W
1985 CITROEN BX 19GT C1TBX
1991 CITROEN BX 19TZI AUTO A/C BXi 19
1994 CITROEN XANTIA 1.8 SXi M908HRY
2003 Rover 25 1.6i XL L33CHT
x 70

Re: Wiring to coil - BX19 TRS 1989 - and HP pump priming

Post by Tim Leech » Wed Sep 07, 2016 5:49 pm

Cliffs beat me to it, the spare wire doesn't get used on uk models.
1963 VW BEETLE 1200
1985 BX 19GT Mk1
1991 BX 19TZI Auto A/C
1994 Xantia 1.8i SX
1972 Morris Marina 1.8 SDL
1979 Rover SD1 V8-S
1980 Morris Marina 1.7HL
2002 Rover 75 CDTi Connossieur SE AUTO Nav
2003 Rover 25 1.6i XL 5 DR

User avatar
Mark.T
Confirmed BX'er
Posts: 47
Joined: Sat Jun 02, 2007 12:19 pm
Location: Melbourne, Australia
x 2

Re: Wiring to coil - BX19 TRS 1989 - and HP pump priming

Post by Mark.T » Mon Sep 12, 2016 2:23 pm

Thanks for confirming. Just need to get steering alignment sorted

Sent from my Nexus 5 using Tapatalk
Mark T.
Melbourne, Australia
BX16 TRS Auto (Series 1)
BX19 TRS (Series 2)
C3 Pluriel